Degraded Performance // Image Asset Upload
Incident Report for Ovrture
Postmortem

Good evening Ovrture users,

This document details the cause and events occurring immediately after Ovrture’s incident on November 15, 2019 as well as the steps we are taking to mitigate the impact of future outages like this one in the future.

On November 15, 2019, the API Ovrture uses with Kraken for image compressing affected the ability to upload image assets into the system. This degraded performance occurred from 11:40 AM. to 5:22 PM.

The Ovrture team was the first to notice this issue. Ovrture investigated the issue and discovered that it was occurring because of the problems that the image compression tool was experiencing. Due to unusually high demand, the compression tool’s cluster's performance had been degraded, with some requests failing. They had to provision new machines to resolve the issue.

Things we will improve to make sure issues like this do not happen again in the future:

-Ovrture will be exploring other options for image compression and have a backup system in place in case anything happens to the primary source.

We are very sorry for any inconvenience this incident may have caused on November 15 and we will continue to work hard to make sure something like this doesn’t happen again.

Onward,

Gideon and the Ovrture Team

Posted Nov 16, 2019 - 22:52 UTC

Resolved
This incident has been resolved. You can now upload image assets as usual. Thank you for your patience as this was resolved. We will continue to monitor the situation and will publish a postmortem in the next 24 hours.
Posted Nov 15, 2019 - 22:32 UTC
Monitoring
We are currently experiencing an issue in regard to uploading image assets within Ovrture. This issue has been identified and is in the process of being fixed.
Posted Nov 15, 2019 - 18:33 UTC
This incident affected: ALL (Database).