Degraded Performance // Vimeo Video Player
Incident Report for Ovrture
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 14:41 UTC
Monitoring
We are currently experiencing an issue in regard to the Vimeo Video Player within Ovrture. This issue has been identified, a fix has been implemented, and results are being monitored.

For more information: https://www.vimeostatus.com/#
Posted Oct 19, 2020 - 14:23 UTC