Degraded Performance // Printbridge Functionality
Incident Report for Ovrture
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 16:05 UTC
Identified
We are currently experiencing an issue in regard to the Printbridge functionality within the platform. This issue has been identified and a fix is being implemented.
Posted Sep 20, 2021 - 11:47 UTC